RETRO STUFF

[Win2k Section]


DOS Win 3.1 Win 95 Win 98 Win 2k Win XP Mac OSX Classic MAC
Amiga Apple IIGS Atari 8-bit C= 64 C= 128 TI 99/4a Tandy COCO3 Mattel Aquarius
Windows 2000 (Service Pack 4) Stuff
This web page is dedicated to Windows 2000 (Professional in particular). Don't ask why, but I feel the need to see how far Windows 2000 can be taken in moderm times (2016 atm). In that vain, I'll document the steps and files used to get Windows 2000 to the end result (hopefully evolving as new patches and files are released), and the software I get installed and working. Although I'd like to do this on real hardware, it isn't practical for testing patches/software, so I'll be using VMware Workstation v12.1 to host a Win2k Pro virtual machine.
Just a word of warning; I can get long winded and ramble. I'll do my best to go back and clean up areas where I ramble. I'm also coding this page(s) with HTML 3.2 compliance because I want to be able to access the site from old browsers on various platforms such as DOS, Windows 95/98, Amiga and Classic Macs.
Installation & Updates
To start things off, you're going to need a Windows 2000 Pro install disk or ISO image if you're installing in a VM as I'm doing. I happen to have an original Win 2k Pro CD from back in the day but if you need the source media, I suggest checking out Amazon or Ebay for a copy. I'm not going to bother telling you how to install Windows, so get er done and move on to the next step.
  • 1. Install Service Pack 4 which is cummulative, so you don't need any previous service packs.
  • 2. You won't be able to install VMware tools until you install Microsoft Security update MS04-011. To download the security update, see Security Update for Windows 2000 (KB835732). Even though you will be able to install v10.1 of the VMware tools, the ThinPrint drivers aren't going to work.
  • 3. Install Windows 2000 SP5.1 (SP 5.2 is not finished as of 1/30/16)
  • 4. Install Windows2000-UURollup-v11-d20141130-x86-ENU (update.exe file is inside the update folder; run that)
  • Once this update is installed there will be a program in programs>accessories>system tools - called "Application Compatibility Launcher". You will need to use this program to launch some program installers that won't run because they detect it's not Windows XP. Simply start the program and drag and drop the installer executable into the window it opens.

  • 5. Install DirectX 9.0c (March 2009 release)
  • 6. Install gdiplus.dll fix - Just extract and copy the gdiplus.dll into your system32 directory.
Programs that only require SP4 and nothing un-official
Updates
Drivers
Programs that require SP5.1 or higher and Rollupv11 from above
Internet
  • Firefox 43.0.1 - Doesn't require the "Application Compatibility Launcher, just the unnoffical service pack 5.1".
  • Firefox 44.00 - Install & runs fine using the "Application Compatibility Launcher" when above updates are installed.
  • Adobe Flash 20.0 Plugin for FF - Doesn't require the "Application Compatibility Launcher".
  • qBittorrent v3.3.3 - Really nice bittorrent client with no ads or crap
  • mIRC 7.43 - Best IRC client ever made!
Applications
  • Calibre v1.48.0 - Really nice eBook management software.
  • Google Picasa v3.9 - Nice photo collection organizer and editor
  • VLC 2.22 - Install & runs fine using the "Application Compatibility Launcher".
  • Winamp 5.621 - Doesn't require the "Application Compatibility Launcher".
  • WinSplit Revolution v11.04 - MUST HAVE APP - Lets you do all kinds of window positioning
  • PicPick v4.1.1 - Nice screen grabber (I like this version best)
Utilities